Page 1 of 1
Forum

Welcome to the Tweaking4All community forums!
When participating, please keep the Forum Rules in mind!

Topics for particular software or systems: Start your topic link with the name of the application or system.
For example “MacOS X – Your question“, or “MS Word – Your Tip or Trick“.

Please note that switching to another language when reading a post will not bring you to the same post, in Dutch, as there is most likely no translated for the post!





ConnectmeNow - NFS ...
 
Share:
Notifications
Clear all

ConnectmeNow - NFS doesn't allow -o options


 lax
(@lax)
Active Member
Joined: 4 weeks ago
Posts: 6
Topic starter  

It seems that on Big Sur, nfs mounts need:

sudo mkdir /Volumes/mount_name
sudo mount -o vers=4,resvport -t nfs server:/export/fs /Volumes/mount_name

 

to properly mount .. But I can't access the NSF options.(-o) config.

Any suggestions?


ReplyQuote
Topic Tags
 Hans
(@hans)
Noble Member Admin
Joined: 8 years ago
Posts: 1758
 

Hi Lax,

The options are disabled when you choose the "Default mount (mounts in /Volumes)".

To enable the options choose "Use custom Path instead of /Volumes/" ...

Hope this fixes the problem 😉 


ReplyQuote
 lax
(@lax)
Active Member
Joined: 4 weeks ago
Posts: 6
Topic starter  

The option now shows, but I still can't mount an nfs server from Linux through the app. Only through the command line.


ReplyQuote
 Hans
(@hans)
Noble Member Admin
Joined: 8 years ago
Posts: 1758
 

What did you enter for the options?

I'm not very experienced with NFS, but I think you need to enter this for that option field:

vers=4,resvport

ReplyQuote
 lax
(@lax)
Active Member
Joined: 4 weeks ago
Posts: 6
Topic starter  
Posted by: @hans

What did you enter for the options?

I'm not very experienced with NFS, but I think you need to enter this for that option field:

vers=4,resvport

Yes, that's what I used. No joy. Manually with sudo on a terminal it works.

 


ReplyQuote



 Hans
(@hans)
Noble Member Admin
Joined: 8 years ago
Posts: 1758
 

Apologies for the delayed response.
Not being a NFS expert I did need to do some tests (had to setup a NFS share first).

Indeed ... it seems the option resvport requires execution by sudo, and CMN does not support sudo commands (thanks to Apple's security precautions).
So I unfortunately do not have a work-around for that. 

The mount_nfs man page suggests you may not need resvport, but I see it depends on server requirements:

resvport

Use a reserved socket port number.  This is useful for mounting servers that require clients to use a reserved
port number on the mistaken belief that this makes NFS more secure. (For the rare case where the client has a trusted root account but untrustworthy users and the network cables are in secure areas this does help, but for  normal desktop clients this does not apply.)

Did you try it with these parameters? (again: not sure how critical the reserved socket port number is, it worked for my QNAP)

vers=4,nfc

 

Obviously, the option has nothing to do with reserved port numbers. Not being a NFS expert, I for some reason keep using it 😜 

nfc

Convert name strings to Unicode Normalization Form C (NFC) when sending them to the NFS server. This option may be used to improve interoperability with NFS clients and servers that typically use names in the NFC form.


ReplyQuote
 Hans
(@hans)
Noble Member Admin
Joined: 8 years ago
Posts: 1758
 

Almost forgot to mention this:

When the Preferences window is open, press and hold CTRL + Alt + Command to reveal the "Show debug log" button.
The debug log will show the command line statement for "custom path" mounts, which may be helpful debugging those parameters (even though not all system error messages are useful).


ReplyQuote
 lax
(@lax)
Active Member
Joined: 4 weeks ago
Posts: 6
Topic starter  
Posted by: @hans

Did you try it with these parameters? (again: not sure how critical the reserved socket port number is, it worked for my QNAP)

Actually , my QNAP .. I use Apple's built-in AFP and works great!. I did try with nfc and no joy. For linux, I, have "insecure" in order not to need rsrvport

EDITED: These settings worked today!!!!. In the Linux /etc/exports file, this is the setting

(sec=sys:krb5:krb5i:krb5p,rw,insecure,sync,no_root_squash,no_all_squash,no_subtree_check)

Joy! .

Will try the log. That's neat!

This post was modified 1 day ago 3 times by lax

Hans liked
ReplyQuote
 lax
(@lax)
Active Member
Joined: 4 weeks ago
Posts: 6
Topic starter  

For anybody else following this:

In your Linux /etc/exports file, give these permissions to the export

/path/nfs_mount   <localnetwork>/24(sec=sys:krb5:krb5i:krb5p,rw,insecure,sync,no_root_squash,no_all_squash,no_subtree_check)

 

Then create a mount point in your system ex:

mkdir ~/Mountpoints/nfs_mount_name

 

And so in the ConnectmeNow for type NFS, use custom path (use above) and NFS options -d (vers=4,resrvport). Obviously adapt to your network and server names!

I also changed my iptables firewall settings on the server to allow TCP/UDP 2049 from the local network. Didn't test without it

Seems to have finally worked for me

This post was modified 1 day ago 2 times by lax

ReplyQuote
 lax
(@lax)
Active Member
Joined: 4 weeks ago
Posts: 6
Topic starter  

REQUEST:

The nfs mount point name that is chosen seems to include the server name

CMD: mount_nfs -o vers=4,rsrvport "<server_dns_name>:/raid_storage/nfs" "/Users/<user>/Mountpoints/nfs (<server_dns_name>)"

 

What i *really* need is just the name and NOT the full path with the server!

Can we change the CMD to just use the Menu Label ?>


ReplyQuote



 Hans
(@hans)
Noble Member Admin
Joined: 8 years ago
Posts: 1758
 

Thanks Lax for the extensive info! Awesome 👍  🙂 

As for your question on the mount path;

Under advanced settings of a share, there is the option "Use custom path as absolute oath (entered directory will be the mountpoint)".
Granted, it is well hidden ... just to avoid that less advanced users make a potential mess of things.

When this option is enabled, the "Use custom path instead of /Volumes/" path will be the exact path of your mount.

So you can type any path you'd like and any directory name you'd like.

Note: I hope this comes across right, since I find it hard to capture this in words 😉 


ReplyQuote

Like what you see and you'd like to help out? 

The best way to help is of course by assisting others with their questions here in the forum, but you can also help us out in other ways:

- Do your shopping at Amazon, it will not cost you anything extra but may generate a small commission for us,
- send a cup of coffee through PayPal ($5, $10, $20, or custom amount),
- become a Patreon,
- donate BitCoin (BTC), or BitCoinCash (BCH).

Share: