Page 1 of 1
Forum

Welcome to the Tweaking4All community forums!
When participating, please keep the Forum Rules in mind!

Topics for particular software or systems: Start your topic link with the name of the application or system.
For example “MacOS X – Your question“, or “MS Word – Your Tip or Trick“.

Please note that switching to another language when reading a post will not bring you to the same post, in Dutch, as there is no translation for that post!



Oculus Virtual Desk...
 
Share:
Notifications
Clear all

[Solved] Oculus Virtual Desktop showing black screen - how to fix it

26 Posts
5 Users
3 Reactions
75.1 K Views
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2706
Topic starter  

Did you try hooking up a monitor?


   
ReplyQuote
(@Anonymous)
Joined: 1 second ago
Posts: 0
 

@hans oh, and monitor is on. if that what you mean..


   
ReplyQuote
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2706
Topic starter  

Yes that is what I meant, and connected to your computer I presume.

Are you using a laptop? What kind of model/type/configuration?


   
ReplyQuote
(@Anonymous)
Joined: 1 second ago
Posts: 0
 

@hans emm...

its dell e6430, 16 gb ram, external gpu msi gtx970... guess it can be external gpu cause this? but im not experienced any issues with remote desktops i worked before...


   
ReplyQuote
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2706
Topic starter  

Ouch - that is at the very low end for VR purposes ... 😱 
Cool that SteamVR games work OK though. 👍 

I'm inclined to think the GPU cannot keep up, or doesn't support the "streaming" option (the desktop is recorded as a video, and then compressed and streamed as video to your HMD/Quest). The fact that it is an external GPU may be the cause as well, but to be honest I have no experience with external GPU's.

Did you try Virtual Desktop (native Quest 2 - link)?


   
ReplyQuote
(@Anonymous)
Joined: 1 second ago
Posts: 0
 

@hans yeah. It's kinda lowest GPU for VR, but most games working good on average settings, but sometimes it just can stuck badly for half min, lol. I checked - only GPU I got max loaded all time, while playing any pcvr. Anyway, I set, to power save, with all this  exe files, from YouTube link, to internal GPU. Cuz external one - is performance option, not power saver, as recommended there. Thanks anyway. Hope, maybe, at least, one dev will pass here...

I'm planning to buy virtual desktop, later, one day... Hope, there will be no such issues.


   
ReplyQuote
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2706
Topic starter  

No worries - I'm happy this GPU works for you.
I started VR with a mobile nVidia 1060 GTX GPU in my laptop, which was said to be not sufficient ... well it worked just fine. 😊 

Since you have an external GPU, I assume you have an external PCI box with a desktop card in it?
If so: maybe see and try to get your hands on a little more potent GPU, like a 1060 or 1080. Doesn't even need to be top of the line.
Or maybe see if you can test with one to see if it even makes a difference.

Virtual Desktop: well, you can try it and if it doesn't work, you can always ask for a refund. Make sure you get this version though.
Warning: The version from Steam is not the one you're looking for!!


   
ReplyQuote
(@Anonymous)
Joined: 1 second ago
Posts: 0
 
Posted by: @hans

I assume you have an external PCI box with a desktop card in it?

Yup. Such cards called eGPU. But issue not in card, I think. Bigscreen app shows desktop fine.

If so: maybe see and try to get your hands on a little more potent GPU, like a 1060 or 1080. Doesn't even need to be top of the line.

Sadly, no. Only to buy. But I prefer to buy something much more efficient. And certainly not for laptop. 


   
Hans reacted
ReplyQuote
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2706
Topic starter  

FYI: just ran into a comment on Reddit (where I posted this solution as well), where they suggest that disabling beta (in the Windows Oculus Desktop application) made this trick work. Reddit topic, specific post. Maybe this helps in your case (kind-a doubt it, worth a try though).

Thanks a bunch, this helped. Although not at first, I had to unsubscribe from the beta program, then it worked!


   
ReplyQuote
(@Anonymous)
Joined: 1 second ago
Posts: 0
 

@hans Nope, already tried.

I got virtual desktop now. So i got similar issues there. I just changed from widescreen (1366x768) to 4:3 (1024x768) and it worked. I think, same will be with oculus air link. I will try this later and will comment, if it not worked.


   
ReplyQuote
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2706
Topic starter  

Sounds like your GPU cannot keep up? Interesting ... that sucks 😞 


   
ReplyQuote
Page 2 / 2
Share: