Page 1 of 1
Forum

Welcome to the Tweaking4All community forums!
When participating, please keep the Forum Rules in mind!

Topics for particular software or systems: Start your topic link with the name of the application or system.
For example “MacOS X – Your question“, or “MS Word – Your Tip or Trick“.

Please note that switching to another language when reading a post will not bring you to the same post, in Dutch, as there is no translation for that post!




Oculus Virtual Desk...
 
Share:
Notifications
Clear all

Oculus Virtual Desktop showing black screen - how to fix it

Page 1 / 2

 Hans
(@hans)
Noble Member Admin
Joined: 9 years ago
Posts: 2187
Topic starter  

(not to be confused with the excellent application by Guy Godin!)

In some laptop configurations, the virtual desktop button seen in the Rift dashboard (or when using the Quest with Link or Air Link) produces a black screen.
This is somehow related to the GPU (integrated or discrete) being used.
This is how I got it fixed:
 
Go to Windows Settings -> System  -> Display -> Graphics Settings (way at the bottom).
Under "Graphics performance preference" -> "Choose an app to set preference" -> "Desktop app".
Click "Browse" and select:
 
C:\Program Files\Oculus\Support\oculus-runtime\OVRServer_x64.exe
 
Click "Add".
Select "Options" and set it to "Power saving", and click "Save".

 

 
Restart the Oculus software and Virtual Desktop now works properly.
Tip (thanks pakrodfor): It is recommended to reboot your PC after making these changes.
 
This worked for me on an 2020 AsusROG with an nVidia 2070.

ReplyQuote
(@admbacca)
New Member
Joined: 6 months ago
Posts: 1
 

Thank you so, so much. I have an MSI gs63vr, and this fixed this months-long issue perfectly. It didn't want to run the dedicated graphics card for whatever reason and I think that's what it was automatically using. Switched to power saving, running the intel hd 630, works like a charm. You're a life saver.

Quest 2 running air link

i7-7700hk
16gb ram
gtx 1060 6bg (what the Quest 2 is using)
Intel HD graphics 630 (what the oculus virtual desktop is now using)


Hans liked
ReplyQuote
(@pakrodfor)
New Member
Joined: 6 months ago
Posts: 1
 

@hans Thanks, this worked for me.

But, with an IMPORTANT EXTRA step:

Restart Your PC after changing the setting

It didn't work for me by simply restarting Oculus software. I had to restart Windows.

I thought I'd comment, as this is one of the first results when Googling for this.

Thanks!

This post was modified 6 months ago by pakrodfor

Hans liked
ReplyQuote
 Hans
(@hans)
Noble Member Admin
Joined: 9 years ago
Posts: 2187
Topic starter  

@pakrodfor

Thanks for the suggestion 👍 - Especially under Windows, it never hurts to reboot, especially when stuff gets cached.
On my Windows 10 machine I did not reboot in between while testing, but that could also be just a matter of getting lucky. 😊 


ReplyQuote
 Hans
(@hans)
Noble Member Admin
Joined: 9 years ago
Posts: 2187
Topic starter  

@admbacca 

Excellent - good to hear! Thanks for sharing that this worked for you as well. 👍 😊 


ReplyQuote


(@itssetsunai)
New Member
Joined: 6 months ago
Posts: 2
 

I switched it to power saving restarted my laptop and all but it was using the intel uhd instead of the 3050ti which made it not run any game at all and some said that I had to have it in performance mode not power saving 


ReplyQuote
 Hans
(@hans)
Noble Member Admin
Joined: 9 years ago
Posts: 2187
Topic starter  

@itssetsunai 

Did you set any other executables besides "OVRServer_x64.exe"?


ReplyQuote
(@itssetsunai)
New Member
Joined: 6 months ago
Posts: 2
 

@hans no I didn't am I supposed to?


ReplyQuote
 Hans
(@hans)
Noble Member Admin
Joined: 9 years ago
Posts: 2187
Topic starter  

@itssetsunai 

No, I just wanted to make sure you did not by accident picked any other exe's ... 😊 

It's been a while that I needed to do this, and posted this fix also in the Oculus forum and on Reddit.
You're the first one (that I'm aware of) that reported it to not work and make things even worse.

Maybe a good idea to share the laptop brand and model you have - just in case others run into this as well.

In the meanwhile (the may take a minute since I'm not home this week) I'll try to see and find what has changed on my setup, since there have been a few updates and I'm already running Windows 11 by now. 


ReplyQuote
(@amessiah)
Active Member
Joined: 4 months ago
Posts: 7
 

im done all this steps, but now im getting yellow picture over black screen (and it start to work much faster).


ReplyQuote


 Hans
(@hans)
Noble Member Admin
Joined: 9 years ago
Posts: 2187
Topic starter  

amessiah - well that doesn't look right ...

I'm running Windows 11 and the Oculus Virtual Desktop works for me.

The following Oculus files are set to Power Saving (Intel UHD Graphics)

C:\Program Files\Oculus\Support\oculus-runtime\OVRRedit
C:\Program Files\Oculus\Support\oculus-runtime\OVRServiceLauncher.exe
C:\Program Files\Oculus\Support\oculus-runtime\OVRServer_x64.exe

 

So this is what I'm seeing on my newer laptop (Asus ROG with nVidia 2070). Maybe you can test again with all these 3 set 

On my previous laptop (Razer) I only needed to set OVRServer_x64.exe - as confirmed by quite a few users, not just here, but on Reddit and the Oculus support forum as well. But it seems this doesn't work for all.

Another thing to keep in mind: SteamVR offers access to the PC Desktop as well from their main window (in your Quest start SteamVR, on the bottom row, on the right if I remember correctly, you'll see a button for this).


ReplyQuote
(@amessiah)
Active Member
Joined: 4 months ago
Posts: 7
 

@hans not helped. I restarted PC too. I guess, I'm in trouble with that...

Steam VR not showing desktop too, but a bit different - with some blurred lines over black screen. Who I need to contact to deal with this? I thought here some dev specialists supposed to be?

P.s. Games with steamVR and just pcvr working fine..

 

This post was modified 4 months ago by amessiah

ReplyQuote
 Hans
(@hans)
Noble Member Admin
Joined: 9 years ago
Posts: 2187
Topic starter  

Sorry to hear that didn't help. 😕

I'm just a VR user, like you, no VR devs or special VR skills here, I've just been playing in VR already since 2016. 😜 

Before I figured out this solution I did find that connecting a monitor to my laptop fixed the problem as well.
Note: Monitor should be ON. Just see if that fixes the issue.

Some thoughts;

1) Since it doesn't work in either cases (Oculus/SteamVR), then I would think something may be preventing your Windows desktop from being "recorded" (mirrored or whatever we would like to call this). I mean; I have never seen it fail in SteamVR ...

Do you happen to be running certain remote desktop software? I read somewhere that these may conflict with Oculus and SteamVR.
Maybe you have some very aggressive AntiVirus protection running? For example, certain applications or profiles protect the user by blocking screen recording.

2) What kind of configuration are you using?

3) I assume you already did this, just in case you didn't: make sure your drivers and Windows are up to date.


ReplyQuote
 Hans
(@hans)
Noble Member Admin
Joined: 9 years ago
Posts: 2187
Topic starter  

While trying to see if I could find some helpful info for you, I did run into a Reddit post where they fixed it by disabling HDR in their Windows settings.

Windows 10: Goto display settings -> Windows HD color settings -> disable HDR.

Note: I haven't tried this myself (I'm running Windows 11) ...


ReplyQuote
(@amessiah)
Active Member
Joined: 4 months ago
Posts: 7
 

@hans im using win10. my all HDR settings was off..


ReplyQuote


Page 1 / 2

Like what you see and you'd like to help out? 

The best way to help is of course by assisting others with their questions here in the forum, but you can also help us out in other ways:

- Do your shopping at Amazon, it will not cost you anything extra but may generate a small commission for us,
- send a cup of coffee through PayPal ($5, $10, $20, or custom amount),
- become a Patreon,
- donate BitCoin (BTC), or BitCoinCash (BCH).

Share: