Page 1 of 1
Forum

Welcome to the Tweaking4All community forums!
When participating, please keep the Forum Rules in mind!

Topics for particular software or systems: Start your topic link with the name of the application or system.
For example “MacOS X – Your question“, or “MS Word – Your Tip or Trick“.

Please note that switching to another language when reading a post will not bring you to the same post, in Dutch, as there is no translation for that post!



QNAP QTS 5.x - KODI...
 
Share:
Notifications
Clear all

QNAP QTS 5.x - KODI 19.x - MySQL/MariaDB - FIX: Browsing TV Shows no longer working properly

1 Posts
1 Users
0 Likes
1,027 Views
 Hans
(@hans)
Famed Member Admin
Joined: 9 years ago
Posts: 2236
Topic starter  

When running a shared MySQL database on a QNAP that runs and older MariaDB 5.x version database for KODI, the you may run into issue with KODI 19.x.
Whenever selecting a TV Show, it will not open the TV Show folder, but rather show me options to browse to the location manually.

This appears to be an incompatibility issue with older MariaDB version (5.x).
This is how you can fix this issue:

  1. On your QNAP, in App Center, make sure to install MariaDB 10 (or newer).
  2. Once installed, open it and follow the migration steps. Mine gave an error, but after re-opening the new version, it worked.
  3. Next: Open the old MariaDB (5.x) and disable it:

     


     

  4. Make sure to take note of the port number as it has been used with MariaDB 5.x, which by default is 3306 - KODI will be relying on this number!
  5. Go to MariaDB 10.x, make sure it's enable it, and set the port number to the one use in the old MariaDB.
    Also take note of the "domain socket" - we will need this to configure phpMyAdmin.
    Click "Apply" which will restart the MariaDB service.
  6. Next go to the Web share and look for the config.inc.php file for phpMyAdmin (/Web/phpMyAdmin/config.inc.php).
    You can either go their with your regular file browser, or QNAP's FileStation.
    Edit the config.inc.php file (when using QNAP FileStation: make sure Text Editor is installed and active on your QNAP - see QNAP App Center!) and add these lines:
    (make sure port number [3306] and socket filename match your configuration [/var/run/mariadb10.sock]!)
    port: $cfg['Servers'][$i]['port'] = '3306';
    socket: $cfg['Servers'][$i]['socket'] = '/var/run/mariadb10.sock';
  7. Now stop phpMyAdmin and restart it in App Center. You should now be able to access your databases that have been migrated to MariaDB 10.x.
    Also: KODI 19.x now works properly again as well.

ReplyQuote
Share: