Page 1 of 1
Forum

Welcome to the Tweaking4All community forums!
When participating, please keep the Forum Rules in mind!

Topics for particular software or systems: Start your topic link with the name of the application or system.
For example “MacOS X – Your question“, or “MS Word – Your Tip or Trick“.

Please note that switching to another language when reading a post will not bring you to the same post, in Dutch, as there is no translation for that post!



Share:
Notifications
Clear all

[Solved] Dark mode (v4.0.12) issues?

13 Posts
2 Users
0 Likes
396 Views
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2678
Topic starter  

Guido reported issues with 4.0.12 in dark mode, concerning "details" and "advanced" appearing very large and in front of everything else.

Here two screenshot what it looks like on my Macbook Pro M1, running Sonoma 14.1.2.


   
ReplyQuote
(@Anonymous)
Joined: 1 second ago
Posts: 0

   
ReplyQuote
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2678
Topic starter  

Thanks for posting the screenshots ...
That's weird for sure. I see the green switches - which are intended for the dark theme, just like the "Details" and "Advanced" text. Yet your window is matching the light mode.

I'd love to be able to reproduce this, so I can fix it.

What macOS version are you running?
And what are you "Appearance" settings in the macOS setting?

Note: I tested Light/Dark/Auto and none of these show the windows like yours. I have tested with macOS Sonoma 14.1.2 and 14.2 on a M1 Macbook Pro.

This is what it looks like on my M1:


   
ReplyQuote
(@Anonymous)
Joined: 1 second ago
Posts: 0
 

macOS Sonoma 14.2 and 14.3 Beta 1. No difference. 

 


   
ReplyQuote
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2678
Topic starter  

I've done some more testing, even on virtual machines and on Intel Mac's, even Mac's that I had to patch with OpenCore to run Sonoma. 
Whatever I try; I cannot get the effect you're seeing.

Your screenshot show more blue/gray tints than mine. Could this be related?

Maybe a display specific setting? (color profile maybe?)

I tested with an external screen and with the build-in screen of my Macbook Pro.

Could this maybe a contrast setting (on your Mac, under accessibility -> display)?

 

Unrelated, as it didn't make a difference when I just tried it on my Mac, but I'm being curious: what does multicolor accent color do?


   
ReplyQuote
(@Anonymous)
Joined: 1 second ago
Posts: 0
 

It seems that my Mac is the special one as always. ;-)


   
ReplyQuote
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2678
Topic starter  

Would you mind trying this command in Terminal?

defaults read -g AppleInterfaceStyle

On all my 4 Mac's, it shows this when the mode is dark (manual set to dark, or automatically set to dark):

Dark

And this for light mode something like this (key being that it "does not exist"):

2023-12-17 10:22:08.908 defaults[52860:2046507]
The domain/default pair of (kCFPreferencesAnyApplication, AppleInterfaceStyle) does not exist

 

Can you also try, I believe you already did - just making sure, to manually set your Mac to "Dark", and to "Light" to see what happens?

Reason why I'm asking is that I see a light theme on your Mac, yet the big text and the dark green switches are only shown in these colors for the dark them. So either dark theme isn't detected correctly, or doesn't work proper on your Mac.


   
ReplyQuote
(@Anonymous)
Joined: 1 second ago
Posts: 0
 

I tried the command and I got both answers depending on daytime. I have a second account on my Mac and there the "words" are displayed correctly.


   
ReplyQuote
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2678
Topic starter  

Just to make sure I understand what you wrote:

On your main account you've set the appearance to auto, and at night it shows "dark" and during the day it shows "does not exits".
The other account on that same Mac, does not use "auto" but does show the correct words (dark or does not exist).

Alright so that is not the problem 😞 

Coming back to your first screenshots (second post in this thread): this is what you see in dark mode? Even when forcing dark mode manually?


   
ReplyQuote
(@Anonymous)
Joined: 1 second ago
Posts: 0
 

No, both accounts use auto and the command shows every time the correct result, no matter which account I use. But the behavior of CMN is only wrong on one account. Both are admin accounts. I use the same settings for both accounts. I guess it is an apple issue.


   
ReplyQuote
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2678
Topic starter  

Hmmm, that's odd. Sounds like a setting for that one account is "off" some how.

Can you try this in Terminal:

defaults read -g NSRequiresAquaSystemAppearance 

It should say something like this:

2023-12-19 10:55:58.203 defaults[72830:3270992] 
The domain/default pair of (kCFPreferencesAnyApplication, NSRequiresAquaSystemAppearance) does not exist

However, if one or the other application, or script, modified that, then it may actually show a value.

If so then you may want to remove that value/setting like so:

  1. Set theme to Light.
  2. Remove the setting like so (in Terminal):
    defaults delete -g NSRequiresAquaSystemAppearance
  3. Reboot (!!) your Mac to see if it worked. (You can set appearance back to auto again after rebooting)

This value "NSRequiresAquaSystemAppearance" is used to opt out of dark mode and force aqua (light). This could explain why we see a light theme, yet dark theme controls (green switches and dark vertical text). Apple documentation for "NSRequiresAquaSystemAppearance".


   
ReplyQuote
(@Anonymous)
Joined: 1 second ago
Posts: 0
 

OK. Thanks. That fixed the issue. Maybe it was NightOwl which I used for a long time until Apple implemented the functionality itself. The second account on my Mac was set up after I uninstalled that tool.

You are an unbelievable source of Mac knowledge :-)


   
ReplyQuote
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2678
Topic starter  

Nice!!! 👍 

Super happy to hear it worked.
Well, my knowledge is in part also thanks to what I can find on the Internet 😉 


   
ReplyQuote
Share: