Page 1 of 1
Forum

Welcome to the Tweaking4All community forums!
When participating, please keep the Forum Rules in mind!

Topics for particular software or systems: Start your topic link with the name of the application or system.
For example “MacOS X – Your question“, or “MS Word – Your Tip or Trick“.

Please note that switching to another language when reading a post will not bring you to the same post, in Dutch, as there is no translation for that post!



Share:
Notifications
Clear all

[Solved] Cannot mount an SMB share on windows 10 Pro computer

6 Posts
2 Users
1 Likes
105 Views
(@Anonymous)
Joined: 1 second ago
Posts: 0
Topic starter  

Hi, I came across your application in another forum and thought great what a brilliant application just what I need 😀 . However I cannot get it to work 😪 . I have an iMac Late 2015 running Monterey 12.7.2. I am connected by gigabit ethernet to my Lan via an unmanaged network switch. DHCP and DNS are handled by my ISP router. For storing files I have a networked "Server" which is a Windows 10 pro machine with 10Tb of storage and I use this for my Plex server as well as file server.

I have always had problems connecting my Mac to the network share using the server name "Server" since upgrading from Yosemite but have got round it by using the machines Static IP address. I can use the Go>Connect to Server with a path smb://xx.x.x.xx/documents which connects OK. However my server shuts down each night but not the Mac so in the morning it has disconnected. 

I have set up the application as belo

 If I click on ping it gives me a confirmation OK however the share will not mount. I have tried replacing the the name with the IP address but it still wont mount. Below is the log output

A few things that may be relevant:-

  • My server name SERVER never appears in the Mac network view although other Windows 10 machines do
  • I can ping the IP address but not the name so there is a problem with local name resolution
  • I have SMB v1 disabled on the Windows 10 Server for security reasons
  • From a Powershell Command SMBv2 is enabled
  • Why is the slash in the path field a forward slash but a backslash when using Finder Connect to Server so Server\documents rather than Server/documents?

Many thanks
Fozzie

This topic was modified 3 weeks ago by Anonymous

   
ReplyQuote
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2638
 

So first question: Not mounting.

Are you using a domain controller?
Most likely not, and if that is the case: leave the "Domain" field empty and try again.

Second question: Name resolving.

Yep, I've seen that problem not just on Macs. That is why I prefer using IP addresses.
For proper resolving a local server, you'll need to type ".local" behind the server name.

So for your scenario, this will nog work (assuming "server" is the name of your Windows 10 machine):

ping server

But this will very likely work:

ping server.local

(I had to get used to that as well when I moved to macOS)

This is how I do it : For important devices (eg. your server) I make a DHCP reservation in my modem/router. So in the modem your ISP provided. Basically you're telling the DHCP to use a fixed IP address for the MAC address of your Windows machine. I always pick an easy to remember IP address, like 192.168.1.100 or something like that. So now, when you Windows 10 machine starts, it will ask for an IP address and always will get the same IP address.

Third question: SMB version support.

SMB version support of course depends 100% on what macOS offers.
From what I could find, SMB is supported as of MacOSX 10.7 (Lion) and by default enabled as of 10.9 (Mavericks).
Maybe not relevant, but here is a post by Apple to force SMB 3 on your Mac, but I have not found any confirmation that Monterey (I would assume it does support SMB 3).

ConnectMeNow 100% relies on macOS supporting the needed protocol.

Fourth question: Slash forward or backwards

Well, my Finder uses the slash forward when using Go->Connect to Server (eg. smb://192.168.1.100/Documents ) and so does ConnectMeNow. When using backslashes in Finder (eg. server\path) it will fail to mount. (tried it just now on Sonoma and Ventura)

Slash forward is the common directory separator under macOS and Linux. Only Windows (as far as I know) uses the backslash notation. 

 

I hope this help 😊  -- let me know how this worked out.


   
ReplyQuote
(@Anonymous)
Joined: 1 second ago
Posts: 0
Topic starter  

Many thanks Hans,

I have now got it working.

What did the trick was leaving out both the domain and user name and password. I dont quite understand the latter but it could be that as I have previously connected by Finder it has cached these credentials in keychain although i have no idea where to find them.

Regard slashes you are correct My Bad 🤐. I googled it yesterday and unix always used forward slashes it was Microsoft that screwed it up with MSDos by using backslashes.

I just need to work out how I can get ConnectMeNow to run the same time every morning. (Although the server shuts down every night my Mac does not and is permanently logged in, so the option to run at log-in is not available).

Can this be done with Automator? I've never used this application before but at first glance it doesn't list ConnectMeNow in the list of applications. Maybe I need to create a script? or a Chron Job!!! Have not ventured into this area at all.

Fozzie


   
ReplyQuote
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2638
 

Hi Fozzie,

glad you've got it to work. But you're right ... leaving out the username and password shouldn't even work haha! Windows 10/11 are notoriously know for cause problems and not allowing anonymous or guest logins. Now leaving out the domain: that is as expected. Is suspect folks tend to read this as "workgroup" instead of "domain". It happens - glad it works!

There is no way to control ConnectMeNow with Automator.
However ... you can start ConnectMeNow at startup of your Mac, and just leave it running.
Next you can use the "Mount on Appear" option. When ConnectMeNow sees the server appear in the network, it will try to mount it automatically.
Few things to keep in mind:

1) Under "Preferences" (in CMN, lower left corner of the window) set "Check network every x seconds" to a reasonable time. If you're not in a hurry, use 60 seconds or more. The higher the number, the less it will "ping" the network.

2) For the given share definition, go to the "Advanced Options" tab and check "On Server IP address Appear" - this requires the IP address, but if a mount works with a server name, then that should work as well. The reason why it says "not recommended" is to avoid too much network activity, which we'd like to minimize of course and that's why we set the polling delay as high as acceptable. 

Hope that helps 😊 


   
ReplyQuote
(@Anonymous)
Joined: 1 second ago
Posts: 0
Topic starter  

Many thanks Hans,

Have followed your instructions and will monitor it. When working consistently I will then play around with the option to run a script after mount to backup my mac every morning.

Again many thanks for your help

Regards

Fozzie


   
Hans reacted
ReplyQuote
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2638
 

p.s. tip for auto-mount on appear:

Sometimes the server is already seen in the network before its services are running. In that case you'd have to wait a little bit for the mount to succeed. You can influence this under the advanced tab of an individual share, by playing a little with "Mount Delay" and "Mount attempts". For example set "Mount Delay" to 30 seconds (if that would be appropriate for you server), or maybe set "Mount Delay" to 5 seconds and set "Mount attempts" to something ilke 20. This may take a little testing to find the sweet spot.

Hope this helps 😊 


   
ReplyQuote
Share: