Page 1 of 1
Forum

Welcome to the Tweaking4All community forums!
When participating, please keep the Forum Rules in mind!

Topics for particular software or systems: Start your topic link with the name of the application or system.
For example “MacOS X – Your question“, or “MS Word – Your Tip or Trick“.

Please note that switching to another language when reading a post will not bring you to the same post, in Dutch, as there is no translation for that post!



Wireguard - Asus ro...
 
Share:
Notifications
Clear all

[Solved] Wireguard - Asus router (client) not routing traffic to specific IP address

1 Posts
1 Users
0 Likes
149 Views
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2678
Topic starter  

Recently I ran into this issue with an Asus Router (GT-AX6000) - and encountered this with both the latest official firmware (3.0.0.6.102_21514) and AsusWRT Merlin (3004.388.6_2).

(IP addresses are of course just examples to illustrate)

Location A (192.168.22.x):
We have an OPNSense firewall running a Wireguard server, opened up for one very specific IP address (192.168.22.100) in that LAN.

Location B (192.168.2.x):
We have the Asus router (client) connecting to Location A, so we can reach the specific device located at location A.

OPNSense and the Asus router both show being connected (Wireguard handshake) properly, yet zero traffic went through.
Meaning: traffic from a PC (192.168.2.10) at location B, connected to the Asus, would not route to the IP address (192.168.22.100) on location B.

Note : of course, first makes ure your Wireguard config works. We tested this with Wireguard on a PC and an iPhone before proceeding. Just making sure the config was correct.

 

After quite a bit of tinkering we found a fix:

In the Asus router we seem to have to add a route ...
Go to Advanced Settings -> VPN -> VPN Director and look at the section at the bottom where we can add rules.

Klik the (+) icon to add a rule.

Set Interface to Wireguard, add an optional description (recommended) and enter the destination IP address (192.168.22.100) at location B.

That did the trick ... 😊 


   
ReplyQuote
Share: