Page 1 of 1
Forum

Welcome to the Tweaking4All community forums!
When participating, please keep the Forum Rules in mind!

Topics for particular software or systems: Start your topic link with the name of the application or system.
For example “MacOS X – Your question“, or “MS Word – Your Tip or Trick“.

Please note that switching to another language when reading a post will not bring you to the same post, in Dutch, as there is no translation for that post!



Share:
Notifications
Clear all

[Solved] Lazarus Pascal - Fedora (36) install Lazarus Pascal (in Parallels on a Mac M1)

1 Posts
1 Users
0 Likes
920 Views
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2677
Topic starter  
Took me a bit of tinkering to get Lazarus to run in Fedora (36), in a virtual machine (in Parallels) on an Apple Silicon Mac.

 
1) Install these packages (I hope I didn’t miss one)
 
sudo yum makecache --refresh
sudo yum -y install gtk2
sudo yum -y install gtk2-devel
 
2) next grab fpcupdeluxe-aarch64-linux and install it in a preferred location (I use ~/FPC)

3) First install FPC ONLY, by selecting fixes-3.2  (3.2.x has a known GLIBC issues under Fedora)
 
4) Next install Lazarus trunk ONLY.
 
 
That worked for me … 😊 

   
ReplyQuote
Share: