Page 1 of 1
Forum

Welcome to the Tweaking4All community forums!
When participating, please keep the Forum Rules in mind!

Topics for particular software or systems: Start your topic link with the name of the application or system.
For example “MacOS X – Your question“, or “MS Word – Your Tip or Trick“.

Please note that switching to another language when reading a post will not bring you to the same post, in Dutch, as there is no translation for that post!



Zigbee2MQTT - Error...
 
Share:
Notifications
Clear all

[Solved] Zigbee2MQTT - Error: Failed to connect to the adapter (ZBDongle-E)

1 Posts
1 Users
0 Reactions
231 Views
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2705
Topic starter  

(still learning as I write this)

So Home Assistant seems to have two ways to chat natively with Zigbee devices, as long as you have Zigbee Coordinator (hardware) installed. Which I do, I actually bought one that was recommended on this Home Assistant page, I selected the ITead SONOFF Zigbee 3.0 USB Dongle Plus Model “ZBDongle-E” (EFR32MG21 variant - mine is listed as "V2").

The default way worked very good - hardly any effort to install and get it working.

However ... Since I am still in my experimentation phase, and I did run into some Zigbee devices that didn't quite work as expected, I decided to give Zigbee2MQTT a try.

For some reason Zigbee2MQTT kept failing and the log kept saying that it couldn't connect to the Zigbee Coordinator (make sure to disable the "Zigbee Home Automation" under "Devices & Services").

Log message:

Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)

Seem for this particular dongle we need to specify the chipset/dongle in the config of Zigbee2MQTT (more info).
The ZBDongle-E uses a different chip, the Silicon Labs EFR32MG21 which uses Zigbee Stack EmberZNet (EZSP v8). (adapter settings documentation)

That being said, after explicitly specifying adapter: ezsp Zigbee2MQTT starts successfully.

Here my settings:

Hope this is helpful for other HA users 😊 


   
ReplyQuote
Share: