Page 1 of 1
Forum

Welcome to the Tweaking4All community forums!
When participating, please keep the Forum Rules in mind!

Topics for particular software or systems: Start your topic link with the name of the application or system.
For example “MacOS X – Your question“, or “MS Word – Your Tip or Trick“.

Please note that switching to another language when reading a post will not bring you to the same post, in Dutch, as there is no translation for that post!



Share:
Notifications
Clear all

[Solved] Access Violation on startup twice before App shows up and cannot located Memory card

4 Posts
2 Users
1 Reactions
592 Views
(@Anonymous)
Joined: 1 second ago
Posts: 0
Topic starter  

I am running the program on an Apple Silicon M2 equipped Laptop and recently upgraded to MacOSX version 14.4.

On advise from a good friend, I have already granted ApplePie-Baker full disk access but that unfortunately did not help. I keep getting this error (and twice!) when attempting to start the program:

          ApplePi-Baker

         Access violation.

Press OK to ignore and risk data
             corruption.
Press Abort to kill the program"

After choosing to ignore the warning (twice!), and clicking "Select a Disk", I am greeted with an impressive list of non-existing disk alternatives, none of them being my SD card that under normal circumstances will show up as the only option here.

The last selection menu I saw was:

/dev/disk5 (4GB Apple Disk Image)
/dev/disk7 (9GB Apple Disk Image)
/dev/disk9 (17GB Apple Disk Image)
/dev/disk11 (5GB Apple Disk Image)
/dev/disk513(10GB Apple Disk Image)
/dev/disk15 (4GB Apple Disk Image)

Any clues will be appreciated - I am out of cues...


   
ReplyQuote
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2714
 

Hi tbarms!

Apologies for the late response, and sorry to hear you're running into issue. 

Since you didn't mention the ApplePi-Baker version: did you try the beta yet?
It's an attempt to fix issues like this one, which I cannot reproduce on any of my Macs (Intel and M1). 😊 

Let me know if this version (the beta) fixes this.


   
ReplyQuote
(@Anonymous)
Joined: 1 second ago
Posts: 0
Topic starter  

@hans Thank you my friend - you just saved my day ^_^

The beta works - still lists a number of non existing drives, but the external drive is now detected and I got the image restored with no issues.

All the best wishes from Denmark

Kind regards
Torben Brams


   
Hans reacted
ReplyQuote
 Hans
(@hans)
Famed Member Admin
Joined: 11 years ago
Posts: 2714
 

Awesome! That is good news 😊 

Thanks from The Netherlands ... for now - maybe I should move to Denmark! 😉 


   
ReplyQuote
Share: